blob: bd9221677683edff7af63a71a4d26a2c0616f03a [file] [log] [blame]
SUMMARY = "Run-time type checker for Python"
HOMEPAGE = "https://pypi.org/project/typeguard/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
SRC_URI[md5sum] = "cc43e0eb1dea7e409a74c7f1effc4544"
SRC_URI[sha256sum] = "d830132dcd544d3f8a2a842ea739eaa0d7c099fcebb9dcdf3802f4c9929d8191"
inherit pypi setuptools3 ptest
SRC_URI += " \
file://run-ptest \
"
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
${PYTHON_PN}-typing-extensions \
${PYTHON_PN}-unixadmin \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
DEPENDS += "\
python3-distutils-extra-native \
python3-setuptools-scm-native \
"
RDEPENDS_${PN} += "python3-typing"
BBCLASSEXTEND = "native nativesdk"