| SUMMARY = "Python GObject bindings" |
| SECTION = "devel/python" |
| LICENSE = "LGPLv2.1" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| |
| inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even |
| |
| DEPENDS += "python3 glib-2.0" |
| |
| SRCNAME="pygobject" |
| SRC_URI = " \ |
| http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| " |
| |
| SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90" |
| SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0" |
| |
| S = "${WORKDIR}/${SRCNAME}-${PV}" |
| |
| PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| |
| # python3-pycairo is checked on configuration -> DEPENDS |
| # we don't link against python3-pycairo -> RDEPENDS |
| PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo" |
| |
| RDEPENDS_${PN} += "python3-setuptools" |
| |
| BBCLASSEXTEND = "native" |
| PACKAGECONFIG_class-native = "" |