blob: 7d65287cb0da30d9b6d888314c88df23d473d235 [file] [log] [blame]
SUMMARY = "pandas library for high-performance data analysis tools"
DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
high-performance, easy-to-use data structures and data analysis tools for \
the Python programming language."
HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774"
SRC_URI[md5sum] = "512da48424b85bf198002bdbdf38af5a"
SRC_URI[sha256sum] = "b39508562ad0bb3f384b0db24da7d68a2608b9ddc85b1d931ccaaa92d5e45273"
inherit pypi setuptools3
DEPENDS += " \
${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
"
CFLAGS_append_toolchain-clang = " -Wno-error=deprecated-declarations"
RDEPENDS_${PN} += " \
${PYTHON_PN}-json \
${PYTHON_PN}-numpy \
${PYTHON_PN}-dateutil \
${PYTHON_PN}-pytz \
"