blob: 635de22d20bdea068229f24ed39d9cae785a5524 [file] [log] [blame]
SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
DESCRIPTION = "\
The PyMongo distribution contains tools for interacting with MongoDB \
database from Python. The bson package is an implementation of the BSON \
format for Python. The pymongo package is a native Python driver for \
MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI[md5sum] = "5d166c8f9500c83314deadebb95b6fd5"
SRC_URI[sha256sum] = "076a7f2f7c251635cf6116ac8e45eefac77758ee5a77ab7bd2f63999e957613b"
inherit pypi setuptools3
PACKAGES =+ "${PYTHON_PN}-bson"
FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
RDEPENDS_${PYTHON_PN}-bson += " \
${PYTHON_PN}-datetime \
${PYTHON_PN}-json \
${PYTHON_PN}-netclient \
${PYTHON_PN}-numbers \
${PYTHON_PN}-threading \
"
RDEPENDS_${PN} += " \
${PYTHON_PN}-bson \
${PYTHON_PN}-pprint \
"