blob: ef57b2a1fcd9f473f28ef5042cd4b707b6bf7ee7 [file] [log] [blame]
SUMMARY = "Ultra fast JSON encoder and decoder for Python"
DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
SRC_URI[md5sum] = "875ac729018f3cac786d471422306fa8"
SRC_URI[sha256sum] = "00bda1de275ed6fe81817902189c75dfd156b4fa29b44dc1f4620775d2f50cf7"
inherit pypi ptest setuptools3
SRC_URI += " \
file://run-ptest \
"
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
RDEPENDS_${PN} += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-numbers \
"
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytz \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
BBCLASSEXTEND = "native nativesdk"