blob: b5c8573296e78ab1ecdd9b5fc7585c5c2522a4a1 [file] [log] [blame]
DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
TDD and BDD - using C++11, C++14, C++17 and later."
AUTHOR = "Phil Nash, Martin Horenovsky and others"
HOMEPAGE = "https://github.com/catchorg/Catch2"
LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
SRC_URI = "git://github.com/catchorg/Catch2.git \
"
# v2.7.2
SRCREV = "7c37501b070c0e9ea9cdedbeac2059f0a6b0a8ab"
S = "${WORKDIR}/git"
inherit cmake python3native
do_install_append() {
rm ${D}${datadir}/Catch2/lldbinit
rm ${D}${datadir}/Catch2/gdbinit
rmdir ${D}${datadir}/Catch2/
}
# Header-only library
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"