| SUMMARY = "Line-oriented text editor" |
| HOMEPAGE = "http://www.gnu.org/software/ed/" |
| DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands." |
| |
| LICENSE = "GPLv3+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \ |
| file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \ |
| file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \ |
| " |
| |
| SECTION = "base" |
| |
| CVE_PRODUCT = "gnu:ed" |
| |
| # LSB states that ed should be in /bin/ |
| bindir = "${base_bindir}" |
| |
| # Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/ |
| SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz" |
| UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/" |
| |
| SRC_URI[sha256sum] = "71de39883c25b6fab44add80635382a10c9bf154515b94729f4a6529ddcc5e54" |
| |
| EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| |
| inherit texinfo |
| |
| do_configure() { |
| ${S}/configure |
| } |
| |
| do_install() { |
| oe_runmake 'DESTDIR=${D}' install |
| # Info dir listing isn't interesting at this point so remove it if it exists. |
| if [ -e "${D}${infodir}/dir" ]; then |
| rm -f ${D}${infodir}/dir |
| fi |
| } |