| SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions" |
| HOMEPAGE = "https://github.com/nexB/license-expression" |
| |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa" |
| |
| SRC_URI[md5sum] = "fd4cb295cc345be1071274cdbd81c969" |
| SRC_URI[sha256sum] = "7960e1dfdf20d127e75ead931476f2b5c7556df05b117a73880b22ade17d1abc" |
| |
| inherit pypi ptest setuptools3 |
| |
| RDEPENDS_${PN} += "\ |
| ${PYTHON_PN}-booleanpy \ |
| " |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS_${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |