blob: 57f36f10f5f2189742a6550593beb4effa43b948 [file] [log] [blame]
SUMMARY = "Temp placeholder for skeleton function"
DESCRIPTION = "Temp placeholder for skeleton repository"
HOMEPAGE = "http://github.com/openbmc/skeleton"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
inherit obmc-phosphor-chassis-mgmt
inherit obmc-phosphor-event-mgmt
inherit obmc-phosphor-fan-mgmt
inherit obmc-phosphor-flash-mgmt
inherit obmc-phosphor-policy-mgmt
inherit obmc-phosphor-sensor-mgmt
inherit obmc-phosphor-system-mgmt
DEPENDS += "glib-2.0"
RDEPENDS_${PN} += "python-subprocess python-tftpy"
SRC_URI += "git://github.com/openbmc/skeleton"
SRCREV = "831188fedd74d86e137ec0c8e39c7395548ad480"
S = "${WORKDIR}/git"
do_compile() {
oe_runmake all
}
do_install() {
install -d ${D}/${sbindir} ${D}${libdir}
for i in ${S}/bin/*.py ${S}/bin/*.exe; do
install $i ${D}/${sbindir}
done
install ${S}/bin/libopenbmc_intf.so ${D}/${libdir}
}