| SUMMARY = "Line-oriented text editor" |
| HOMEPAGE = "http://www.gnu.org/software/ed/" |
| DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands." |
| |
| LICENSE = "GPL-2.0-only" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \ |
| file://ed.h;endline=20;md5=504a90a78b045972e2fd2f3fc418c195 \ |
| file://main.c;endline=17;md5=cf9d322b0ac4445ca2299c61ee175365 \ |
| " |
| |
| SECTION = "base" |
| |
| CVE_PRODUCT = "gnu:ed" |
| |
| # LSB states that ed should be in /bin/ |
| bindir = "${base_bindir}" |
| |
| # Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/ |
| SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz" |
| UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/" |
| |
| SRC_URI[sha256sum] = "ce2f2e5c424790aa96d09dacb93d9bbfdc0b7eb6249c9cb7538452e8ec77cd48" |
| |
| EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| |
| inherit texinfo |
| |
| do_configure() { |
| ${S}/configure |
| } |
| |
| do_install() { |
| oe_runmake 'DESTDIR=${D}' install |
| # Info dir listing isn't interesting at this point so remove it if it exists. |
| if [ -e "${D}${infodir}/dir" ]; then |
| rm -f ${D}${infodir}/dir |
| fi |
| } |