blob: 56282902804afd89b519eac04333fd7a0f6b5947 [file] [log] [blame]
SUMMARY = "DataStax Python Driver for Apache Cassandra"
DESCRIPTION = "A modern, feature-rich and highly-tunable Python client \
library for Apache Cassandra (1.2+) and DataStax Enterprise (3.1+) using \
exclusively Cassandra's binary protocol and Cassandra Query Language v3."
HOMEPAGE = "https://github.com/datastax/python-driver"
SECTION = "devel/python"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
SRCNAME = "cassandra-driver"
SRC_URI[md5sum] = "c31bc29989d8b0c7524a38b0e38c8bfb"
SRC_URI[sha256sum] = "83ec8d9a5827ee44bb1c0601a63696a8a9086beaf0151c8255556299246081bd"
DISTUTILS_BUILD_ARGS += " \
--no-libev \
"
DISTUTILS_INSTALL_ARGS += " \
--no-libev \
"
inherit pypi setuptools3
RDEPENDS_${PN} += "\
${PYTHON_PN}-cython \
${PYTHON_PN}-json \
${PYTHON_PN}-misc \
${PYTHON_PN}-multiprocessing \
${PYTHON_PN}-numbers \
${PYTHON_PN}-six \
libevent \
"
DEPENDS += "\
${PYTHON_PN}-cython \
"