blob: 366dec3dc13f3d5b0c9142b855ec56bd420efd2b [file] [log] [blame]
SUMMARY = "Yet Another Python Profiler"
HOMEPAGE = "https://github.com/sumerc/yappi"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee"
SRC_URI[md5sum] = "83237494e7d22df2a31935a1e6650fa6"
SRC_URI[sha256sum] = "ad5fa4caf2859e480ffc4ec3e85615a6f7dea852c8f035f2db723f824ed4ba11"
SRC_URI += " \
file://run-ptest \
"
inherit pypi setuptools3 ptest
RDEPENDS_${PN} += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-pickle \
${PYTHON_PN}-threading \
"
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
${PYTHON_PN}-multiprocessing \
${PYTHON_PN}-profile \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
cp -f ${S}/yappi/yappi.py ${D}/${PTEST_PATH}/
}