blob: eed5f9c1f6a0f73b1426df7d17f5cf5196de8672 [file] [log] [blame]
SUMMARY = "U-Boot bootloader image creation tool"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
SECTION = "bootloader"
DEPENDS = "openssl"
SRCREV = "d0847e6b3eda43d4d2b4f9928a549c3c2d52865f"
UBRANCH = "v2016.05-ast2500"
SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
PV = "v2016.05+git${SRCPV}"
S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
do_compile () {
oe_runmake sandbox_defconfig
oe_runmake cross_tools NO_SDL=1
}
do_install () {
install -d ${D}${bindir}
install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
ln -sf uboot-mkimage ${D}${bindir}/mkimage
}
BBCLASSEXTEND = "native nativesdk"