| SUMMARY = "System load testing utility" |
| DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/" |
| LICENSE = "GPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| |
| SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \ |
| file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \ |
| file://no_daddr_t.patch \ |
| " |
| SRC_URI[sha256sum] = "0ccf437ca1876a3e8a55986c6481697045203a17f5994cb2f5096cd461d18031" |
| |
| DEPENDS = "coreutils-native" |
| |
| PROVIDES = "stress" |
| RPROVIDES_${PN} = "stress" |
| RREPLACES_${PN} = "stress" |
| RCONFLICTS_${PN} = "stress" |
| |
| inherit bash-completion |
| |
| do_install() { |
| oe_runmake DESTDIR=${D} install |
| } |
| |