blob: 70b6e91347b3a941366de143e205ef4e7b55b255 [file] [log] [blame]
SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
and copying files using the block map. The idea is that large file containing \
unused blocks, like raw system image files, can be copied or flashed a lot \
faster with bmaptool than with traditional tools like "dd" or "cp"."
HOMEPAGE = "https://github.com/01org/bmap-tools"
SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRC_URI = "git://github.com/intel/bmap-tools.git"
SRCREV = "9dad724104df265442226972a1e310813f9ffcba"
S = "${WORKDIR}/git"
RDEPENDS_${PN} = "python3-core python3-compression python3-mmap python3-setuptools"
inherit python3native
inherit setuptools3
BBCLASSEXTEND = "native"