blob: 5f5507bc743cfcdd0db6aa51a618a8bb28889d51 [file] [log] [blame]
SUMMARY = "MessagePack implementation for C and C++"
DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small"
HOMEPAGE = "http://msgpack.org/index.html"
LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \
file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \
"
SRC_URI = "https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/msgpack-cxx-${PV}.tar.gz"
SRC_URI[sha256sum] = "23ede7e93c8efee343ad8c6514c28f3708207e5106af3b3e4969b3a9ed7039e7"
S = "${WORKDIR}/msgpack-cxx-${PV}"
DEPENDS += "boost"
inherit cmake pkgconfig
RDEPENDS:${PN}-dev = ""
BBCLASSEXTEND += "native nativesdk"