blob: 307fe905d5ecb4e3f0457c80cb42d2adb1acae67 [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC Event Management"
DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
HOMEPAGE = "https://github.com/openbmc/phosphor-event"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-event-mgmt
inherit obmc-phosphor-sdbus-service
inherit obmc-phosphor-c-daemon
TARGET_CPPFLAGS += "-std=c++11 -fpic"
SRC_URI += "git://github.com/openbmc/phosphor-event"
SRCREV = "d8fbb0a07dc0c68b3f5d074bddca96eccaca14b4"
RDEPENDS_${PN} += "libsystemd"
DEPENDS += "systemd"
S = "${WORKDIR}/git"
INSTALL_NAME = "event_messaged"
do_install() {
install -d ${D}/var/lib/obmc/events/
install -m 0755 -d ${D}${sbindir}
install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
}