| SUMMARY = "Python GObject bindings" |
| HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject" |
| DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more." |
| SECTION = "devel/python" |
| LICENSE = "LGPL-2.1-only" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| |
| GIR_MESON_OPTION = "" |
| |
| inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even |
| |
| python() { |
| if d.getVar('CLASSOVERRIDE') == "class-target" and not bb.utils.to_boolean(d.getVar("GI_DATA_ENABLED")): |
| raise bb.parse.SkipRecipe("GI not available") |
| } |
| |
| DEPENDS += "python3 glib-2.0" |
| |
| SRCNAME="pygobject" |
| |
| SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz" |
| SRC_URI[sha256sum] = "426008b2dad548c9af1c7b03b59df0440fde5c33f38fb5406b103a43d653cafc" |
| |
| S = "${WORKDIR}/${SRCNAME}-${PV}" |
| |
| PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| |
| RDEPENDS:${PN} += " \ |
| python3-io \ |
| python3-pkgutil \ |
| " |
| |
| # python3-pycairo is checked on configuration -> DEPENDS |
| # we don't link against python3-pycairo -> RDEPENDS |
| PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo" |
| PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false," |
| |
| BBCLASSEXTEND = "native" |
| PACKAGECONFIG:class-native = "" |