blob: 458ad8ecf2a99dadcae4f19ef9ee91f9f8b0e6e0 [file] [log] [blame]
require cryptodev.inc
SUMMARY = "A test suite for /dev/crypto device driver"
DEPENDS += "openssl"
SRC_URI += " \
file://0001-tests-Makefile-do-not-use-Werror.patch \
"
EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
do_compile() {
oe_runmake tests
}
do_install() {
oe_runmake install_tests
}
FILES:${PN} = "${bindir}/*"