blob: e15d83b60eaea0f9cd8423ed4ae291dafa38a9ab [file] [log] [blame]
SUMMARY = "Python evdev lib"
HOMEPAGE = "https://github.com/gvalkov/python-evdev"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
SRC_URI[sha256sum] = "8782740eb1a86b187334c07feb5127d3faa0b236e113206dfe3ae8f77fb1aaf1"
inherit pypi setuptools3
do_compile_prepend() {
rm -rf ${S}/evdev/ecodes.c
}
DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
RDEPENDS_${PN} += "\
${PYTHON_PN}-ctypes \
${PYTHON_PN}-fcntl \
${PYTHON_PN}-io \
${PYTHON_PN}-shell \
${PYTHON_PN}-stringold \
"