blob: 16dbc58dc9dce25040c35c62be9c40725eed188d [file] [log] [blame]
# Common code for dbus applications using python.
inherit allarch
inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "python-dbus python-pygobject"
INSTALL_NAME ?= "${PN}"
SCRIPT_NAME ?= "${INSTALL_NAME}.py"
do_install_append() {
# install the script
install -d ${D}${sbindir}
install -m 0755 ${S}/${SCRIPT_NAME} ${D}${sbindir}/${INSTALL_NAME}
}