blob: 0b38d58e4a9dc210eec479fa382726898527270a [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A pure-Python SNMPv1/v2c/v3 library"
2DESCRIPTION = "SNMP v1/v2c/v3 engine and apps written in pure-Python. \
3 Supports Manager/Agent/Proxy roles, scriptable MIBs, asynchronous \
4 operation (asyncio, twisted, asyncore) and multiple transports.\
5"
6HOMEPAGE = "https://pypi.python.org/pypi/pysnmp"
7SECTION = "devel/python"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=280606d9c18f200e03e0c247ac61475a"
10
11SRCNAME = "pysnmp"
12
13SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "387aaa23c168ccc0b59775cfdf519fc0"
16SRC_URI[sha256sum] = "38253fe95cea33f352fb36e85f3c2874043401724300c4888df74835161169d2"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit setuptools
21
22RDEPENDS_${PN} += "python-pycrypto \
23 python-pyasn1 \
24 python-pysmi \
25"