blob: 3394173c86fab77c2d7915232a23af3d445bd06e [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001DESCRIPTION = "Plex86/Bochs LGPL VGABios"
2HOMEPAGE = "http://www.nongnu.org/vgabios/"
3LICENSE = "LGPLv2.1"
4SECTION = "firmware"
5
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006DEPENDS = "dev86-native biossums-native"
Patrick Williamsd849ec72016-08-17 14:59:38 -05007
8LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589"
9
Brad Bishop00111322018-04-01 22:23:53 -040010SRC_URI = "http://savannah.gnu.org/download/vgabios/${BPN}-${PV}.tgz"
Patrick Williamsd849ec72016-08-17 14:59:38 -050011
12SRC_URI[md5sum] = "2c0fe5c0ca08082a9293e3a7b23dc900"
13SRC_URI[sha256sum] = "9d24c33d4bfb7831e2069cf3644936a53ef3de21d467872b54ce2ea30881b865"
14
15PR = "r0"
16
17FILES_${PN} = "/usr/share/firmware/${PN}-${PV}*.bin"
18FILES_${PN}-dbg = "/usr/share/firmware/${PN}-${PV}*.debug.bin"
19
20S = "${WORKDIR}/${PN}-${PV}"
21
22do_configure() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023 # Override to use the native-built biossums tool:
24 sed 's,./biossums,biossums,' -i Makefile
25 sed 's,$(CC) -o biossums biossums.c,touch biossums,' -i Makefile
Patrick Williamsd849ec72016-08-17 14:59:38 -050026}
27
28do_install() {
29 install -d ${D}/usr/share/firmware
30 install -m 0644 VGABIOS-lgpl-latest.bin ${D}/usr/share/firmware/${PN}-${PV}.bin
31 install -m 0644 VGABIOS-lgpl-latest.cirrus.bin ${D}/usr/share/firmware/${PN}-${PV}.cirrus.bin
32}
33