blob: e045431d6bf754a97b9f01e7f4a965e2c7385fc5 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A Python bindings generator for C/C++ libraries"
5
6HOMEPAGE = "https://www.riverbankcomputing.com/software/sip/"
7LICENSE = "GPL-2.0-or-later"
8SECTION = "devel"
9LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303"
10
11inherit pypi setuptools3 python3native
12
13PYPI_PACKAGE = "sip"
Patrick Williams169d7bc2024-01-05 11:33:25 -060014SRC_URI[sha256sum] = "3002df415e168ac3ffe393942dbc7131cb82ade50000e1526f46a88ade26f598"
15
16RDEPENDS:${PN} = " \
17 python3-core \
18 python3-packaging \
19 python3-logging \
20 python3-tomllib \
21 python3-setuptools \
22"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060023
24BBCLASSEXTEND = "native"