blob: 5f518d22d1c33ffabeb494c3994650499e99fcd2 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
8PROVIDES += "virtual/update-alternatives"
9
10SRCREV = "53274f087565fd45d8452c5367997ba6a682a37a"
11PV = "0.1.8+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/opkg-utils"
14
15SRC_URI_append_class-native = " file://tar_ignore_error.patch"
16
17S = "${WORKDIR}/git"
18
19TARGET_CC_ARCH += "${LDFLAGS}"
20
21PYTHONRDEPS = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
22PYTHONRDEPS_class-native = ""
23
24PACKAGECONFIG = "python"
25PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
26
27do_install() {
28 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
29}
30
31do_install_append_class-target() {
32 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${libdir},g'
33}
34
35PACKAGES =+ "update-alternatives-opkg"
36FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
37RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
38RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
39RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
40
41BBCLASSEXTEND = "native nativesdk"