blob: 09ba8cfd93dc2eb28ac1bb5a2052bc611938090c [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Virtual EtherDrive blade AoE target"
2SECTION = "admin"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
Brad Bishopc342db32019-05-15 21:57:59 -04007UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/aoetools/files/vblade/"
8
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05009SRCREV = "a7f48bda5bf1646f6450601049bf4b74053adbb3"
10SRC_URI = "git://github.com/OpenAoE/vblade \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011 file://cross.patch \
12 file://makefile-add-ldflags.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050013 file://gcc-10.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://${BPN}.conf \
15 file://${BPN}.init \
16 file://${BPN}.service \
17 file://volatiles.99_vblade \
18 "
19
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050020S = "${WORKDIR}/git"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050022UPSTREAM_CHECK_URI = "https://github.com/OpenAoE/vblade/archive/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024inherit autotools-brokensep update-rc.d systemd
25
26do_install() {
27 install -D -m 0755 ${S}/vblade ${D}/${sbindir}/vblade
28 install -D -m 0755 ${S}/vbladed ${D}/${sbindir}/vbladed
29 install -D -m 0644 ${S}/vblade.8 ${D}/${mandir}/man8/vblade.8
30
31 install -D -m 0644 ${WORKDIR}/${BPN}.conf ${D}/${sysconfdir}/${BPN}.conf
32 install -D -m 0755 ${WORKDIR}/${BPN}.init ${D}/${sysconfdir}/init.d/${BPN}
33
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
35 install -d ${D}/${sysconfdir}/default/volatiles
36 install -m 0755 ${WORKDIR}/volatiles.99_vblade ${D}/${sysconfdir}/default/volatiles/99_vblade
37 fi
38
39 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
40 install -d ${D}/${bindir}
41 install -m 0755 ${WORKDIR}/${BPN}.init ${D}/${bindir}/
42 install -d ${D}${sysconfdir}/tmpfiles.d
43 echo "d /var/run/${BPN} 0755 root root -" > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
44
45 install -d ${D}${systemd_system_unitdir}
46 install -m 0644 ${WORKDIR}/vblade.service ${D}${systemd_system_unitdir}
47 sed -e 's,@BINDIR@,${bindir},g' -i ${D}${systemd_system_unitdir}/*.service
48 fi
49
50}
51
52INITSCRIPT_NAME = "vblade"
53INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
54
55SYSTEMD_SERVICE_${PN} = "vblade.service"
56SYSTEMD_AUTO_ENABLE = "disable"