Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | SUMMARY = "More routines for operating on iterables, beyond itertools" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/erikrose/more-itertools" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5" |
| 5 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "8fccb480c43d3e99a00087634c06dd02b0d50fbf088b380de5a41a015ec239e1" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 7 | |
| 8 | inherit pypi python_flit_core ptest |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 15 | python3-asyncio \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 19 | python3-statistics \ |
| 20 | python3-pytest \ |
| 21 | python3-unittest-automake-output \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |