blob: 970af477e1606ac436cfef1cec225ff25b9470de [file] [log] [blame]
Milton D. Miller II0e775142016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
2DESCRIPTION = "Phosphor OpenBMC filesytem mount reference implementation."
Brad Bishopcd0ba722018-06-19 15:21:01 -04003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Milton D. Miller II0e775142016-01-20 14:57:54 -06005
Brad Bishopcd0ba722018-06-19 15:21:01 -04006PR = "r1"
Milton D. Miller II0e775142016-01-20 14:57:54 -06007
Brad Bishop021bba32018-07-23 15:25:34 -04008inherit allarch
9
Milton D. Miller II0e775142016-01-20 14:57:54 -060010S = "${WORKDIR}"
11SRC_URI += "file://obmc-init.sh"
12SRC_URI += "file://obmc-shutdown.sh"
13SRC_URI += "file://obmc-update.sh"
14SRC_URI += "file://whitelist"
15
16do_install() {
Milton D. Miller II0111a482016-03-07 14:42:50 -060017 for f in init-download-url init-options
18 do
19 if test -e $f
20 then
21 install -m 0755 ${WORKDIR}/$f ${D}/$f
22 fi
23 done
Milton D. Miller II0e775142016-01-20 14:57:54 -060024 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
25 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
26 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
27 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
28 install -d ${D}/dev
29 mknod -m 622 ${D}/dev/console c 5 1
30}
31
32FILES_${PN} += " /init /shutdown /update /whitelist /dev "
Milton D. Miller II0111a482016-03-07 14:42:50 -060033FILES_${PN} += " /init-options /init-download-url "