blob: 07b966c1c898e0c54d1945ad71a50860b131f209 [file] [log] [blame]
Andrew Jeffery900695b2021-01-13 13:03:50 +10301SUMMARY = "Secure-boot utilities for ASPEED BMC SoCs"
2HOMEPAGE = "https://github.com/AspeedTech-BMC/socsec/"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d50b901333b4eedfee074ebcd6a6d611"
6
7SRC_URI = "git://github.com/AspeedTech-BMC/socsec/;protocol=https;branch=develop"
8
9PV = "1.7+git${SRCPV}"
10SRCREV = "54cdd3b26262e66d2020a04cba55bc8b02090f1a"
11
12S = "${WORKDIR}/git"
13
14inherit python3native setuptools3
15
Patrick Williamsb9799be2021-08-06 09:13:33 -050016RDEPENDS:${PN} += "python3-bitarray"
17RDEPENDS:${PN} += "python3-core"
18RDEPENDS:${PN} += "python3-hexdump"
19RDEPENDS:${PN} += "python3-jsonschema"
20RDEPENDS:${PN} += "python3-jstyleson"
21RDEPENDS:${PN} += "python3-pycryptodome"
Andrew Jeffery900695b2021-01-13 13:03:50 +103022
23BBCLASSEXTEND = "native nativesdk"