blob: 456cb2f9624c39e92d137b517639a0f7204df1cd [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
3DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others."
4BUGTRACKER = "https://github.com/libuv/libuv/issues"
5LICENSE = "MIT"
Patrick Williams520786c2023-06-25 16:20:36 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=74b6f2f7818a4e3a80d03556f71b129b \
7 file://LICENSE-extra;md5=f9307417749e19bd1d6d68a394b49324"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Patrick Williamsb542dec2023-06-09 01:26:37 -05009SRCREV = "96e05543f53b19d9642b4b0dd73b86ad3cea313e"
10SRC_URI = "git://github.com/libuv/libuv.git;branch=master;protocol=https"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
12
13S = "${WORKDIR}/git"
14
15inherit autotools
16
17do_configure() {
18 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
19 oe_runconf
20}
21
22BBCLASSEXTEND = "native"