blob: b83d5fdb43650a4469d55acee537069c7cadf0ff [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a"
12
13DEPENDS = "libevdev udev mtdev libcheck"
14
Andrew Geissler028142b2023-05-05 11:29:21 -050015SRC_URI = "git://gitlab.freedesktop.org/libinput/libinput.git;protocol=https;branch=main \
Andrew Geissler517393d2023-01-13 08:55:19 -060016 file://run-ptest \
Andrew Geissler517393d2023-01-13 08:55:19 -060017 "
Andrew Geissler028142b2023-05-05 11:29:21 -050018SRCREV = "0b005eb64b12603e65a620a77c67ec62fd03f413"
Andrew Geissler517393d2023-01-13 08:55:19 -060019S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
22
23inherit meson pkgconfig lib_package ptest
24
25# Patch out build directory, otherwise it leaks into ptest binary
26do_configure:append() {
27 sed -i -e "s,${WORKDIR},,g" config.h
28 if [ -e "litest-config.h" ]; then
29 sed -i -e "s,${WORKDIR},,g" litest-config.h
30 fi
31}
32
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
35PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
36
37UDEVDIR = "`pkg-config --variable=udevdir udev`"
38
39EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
40 -Ddocumentation=false \
41 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
42 -Dzshcompletiondir=no"
43
44# package name changed in 1.8.1 upgrade: make sure package upgrades work
45RPROVIDES:${PN} = "libinput"
46RREPLACES:${PN} = "libinput"
47RCONFLICTS:${PN} = "libinput"
48
49FILES:${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"