blob: d0c9b5e6293fd2e15d7645b6786084953fd24bb1 [file] [log] [blame]
Gunnar Mills02ac8062017-01-27 13:13:24 -06001SUMMARY = "Phosphor Software Management"
2DESCRIPTION = "Phosphor Software Manager provides a set of system software \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-bmc-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10SOFTWARE_MGR_PACKAGES = " \
11 ${PN}-version \
12"
13PACKAGE_BEFORE_PN = "${PN}-version"
14DBUS_PACKAGES = "${SOFTWARE_MGR_PACKAGES}"
15
16# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
17# handles the rest.
18SYSTEMD_PACKAGES = ""
19
20inherit autotools pkgconfig
21inherit obmc-phosphor-dbus-service
22
23DEPENDS += "autoconf-archive-native"
24DEPENDS += "sdbusplus"
25DEPENDS += "phosphor-dbus-interfaces"
26
27RDEPENDS_${PN}-version += "phosphor-dbus-interfaces sdbusplus"
28
29FILES_${PN}-version = "${sbindir}/phosphor-version-software-manager"
30DBUS_SERVICE_${PN}-version += "xyz.openbmc_project.Software.Version.service"
31
32SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt"
33SRCREV = "af4759e828690e51035c9d11c2a6845d9bb38406"
34
35S = "${WORKDIR}/git"