blob: e42259e5f78b4e88de20ac27f8b20e6f816f6153 [file] [log] [blame]
Brad Bishop02f9a522018-03-09 16:51:57 -05001inherit obmc-phosphor-utils
2
Brad Bishop09806a52018-03-09 00:40:41 -05003SRC_URI += "${@df_enabled(d, 'openpower-ubi-fs', 'file://software.conf')}"
Gunnar Mills1e445242017-11-01 14:09:04 -05004
Brad Bishop8623bbe2018-03-09 00:04:00 -05005install_tmpfile() {
Gunnar Mills1e445242017-11-01 14:09:04 -05006 # /tmp/images is the software image upload directory.
7 # It should not be deleted since it is watched by the Image Manager for
Brad Bishop8623bbe2018-03-09 00:04:00 -05008 # new images.
9
Brad Bishop09806a52018-03-09 00:40:41 -050010 if ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-ubi-fs', 'true', 'false', d)}; then
Gunnar Mills1e445242017-11-01 14:09:04 -050011 install -m 0644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
12 fi
13}
Brad Bishop8623bbe2018-03-09 00:04:00 -050014
15install_tmpfile_df-obmc-ubi-fs() {
16 # Don't install software.conf if obmc-ubi-fs is set since
17 # the bbappend in the meta-phosphor layer already installs
18 # if obmc-ubi-fs is set.
19
20 :
21}
22
23do_install_append() {
24 install_tmpfile
25}