blob: 6fc78dd296c734f2f44b741b50c0d14a7daa7b3f [file] [log] [blame]
Patrick Williams03514f12024-04-05 07:04:11 -05001SUMMARY = "This is gnome-user-share 43.0, a system for easy sharing of user files."
2LICENSE="GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
4
5
6DEPENDS = " \
7 glib-2.0-native \
8 glib-2.0 \
9 systemd \
10"
11
12inherit gnomebase gsettings features_check
13
14REQUIRED_DISTRO_FEATURES = "systemd"
15
16SRC_URI = "git://gitlab.gnome.org/GNOME/gnome-user-share.git;protocol=https;branch=master"
17SRCREV = "a0e790aa9494db9d1b1f48b4fc0d2f78e112044d"
18S = "${WORKDIR}/git"
19
20PACKAGECONFIG ??= "modules"
21PACKAGECONFIG[httpd] = "-Dhttpd=${sbindir}/httpd,,,apache2 mod-dnssd"
22PACKAGECONFIG[modules] = "-Dmodules_path=${libexecdir}/apache2/modules"
23
24FILES:${PN} += "${systemd_user_unitdir}"