blob: c1f5f4ed8eaae18c986f7fd945d5a8a062739b55 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = " C++ binding for Wayland using the most modern C++ technology"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3aae28cc66d61975114c2b14df215407"
4
Patrick Williamsb9af8752023-01-30 13:28:01 -06005SRC_URI = "git://github.com/NilsBrause/waylandpp.git;protocol=https;branch=master \
6 file://0001-include-missing-cstdint.patch"
Patrick Williams92b42cb2022-09-03 06:53:57 -05007
8DEPENDS = "pugixml"
9DEPENDS:append:class-target = " waylandpp-native wayland virtual/egl virtual/libgles2"
10
11S = "${WORKDIR}/git"
12SRCREV = "4321ed5c7b4bffa41b8a2a13dc7f3ece1191f4f3"
13
Andrew Geissler517393d2023-01-13 08:55:19 -060014inherit cmake pkgconfig features_check
15
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050016REQUIRED_DISTRO_FEATURES:class-target = "opengl"
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18EXTRA_OECMAKE:class-native = " \
19 -DBUILD_SCANNER=ON \
20 -DBUILD_LIBRARIES=OFF \
21 -DBUILD_DOCUMENTATION=OFF \
22 -DCMAKE_BUILD_TYPE=Release \
23 -DCMAKE_VERBOSE_MAKEFILE=TRUE \
24"
25
26EXTRA_OECMAKE:class-target = " \
27 -DBUILD_SCANNER=ON \
28 -DBUILD_LIBRARIES=ON \
29 -DBUILD_DOCUMENTATION=OFF \
30 -DBUILD_EXAMPLES=OFF \
31 -DOPENGL_LIBRARY="-lEGL -lGLESv2" \
32 -DOPENGL_opengl_LIBRARY=-lEGL \
33 -DOPENGL_glx_LIBRARY=-lEGL \
34 -DWAYLAND_SCANNERPP="${STAGING_BINDIR_NATIVE}/wayland-scanner++" \
35 -DCMAKE_BUILD_TYPE=Release \
36 -DCMAKE_VERBOSE_MAKEFILE=TRUE \
37 -DCMAKE_EXE_LINKER_FLAGS="-Wl,--enable-new-dtags" \
38"
39
Patrick Williams03514f12024-04-05 07:04:11 -050040do_install:append:class-target() {
41 sed -i -e 's|${S}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
42 sed -i -e 's|${STAGING_DIR_HOST}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
43}
44
Patrick Williams92b42cb2022-09-03 06:53:57 -050045BBCLASSEXTEND += "native nativesdk"