blob: a29d6bce45a54538538d12302f1234015a2729e1 [file] [log] [blame]
Patrick Williams03514f12024-04-05 07:04:11 -05001SUMMARY = "Simple Go-based setuid+setgid+setgroups+exec"
2HOMEPAGE = "https://github.com/tianon/gosu"
3DESCRIPTION = "This is a simple tool grown out of the simple fact that su and sudo have very strange and often annoying TTY and signal-forwarding behavior."
4LICENSE = "Apache-2.0 "
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7GO_IMPORT = "github.com/tianon/gosu"
8SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
9 git://github.com/moby/sys;name=user;destsuffix=${S}/src/github.com/moby/sys;branch=main;protocol=https \
10 git://github.com/golang/sys;name=sys;destsuffix=${S}/src/golang.org/x/sys;branch=master;protocol=https \
11"
12SRCREV = "0d1847490b448a17eb347e5e357f2c0478df87ad"
13#v0.1.0
14SRCREV_user = "c0711cde08c8fa33857a2c28721659267f49b5e2"
15#v0.1.0
16SRCREV_sys = "95e765b1cc43ac521bd4fd501e00774e34401449"
17
18SRCREV_FORMAT .= "_user_sys"
19
20inherit go
21
22CGO_ENABLED = "1"
23
24do_compile:prepend() {
25 # New Go versions has Go modules support enabled by default
26 export GO111MODULE=off
27}
28
29RDEPENDS:${PN}-dev += "bash"