blob: 4d6c06240d21aea54a294f96ff98d0f8664fabed [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "LibTomMath is a number theoretic multiple-precision integer library"
2HOMEPAGE = "https://www.libtom.net/LibTomMath"
3SECTION = "libs"
4LICENSE = "Unlicense"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=23e7e0a32e53a2b1d35f5fd9ef053402"
6
7DEPENDS = "libtool-cross"
8
9SRC_URI = "git://github.com/libtom/libtommath.git;protocol=https;branch=master"
10
Patrick Williams03514f12024-04-05 07:04:11 -050011SRCREV = "95d80fd8229d05dd6cb4ec88bc8d4f5377ff00ef"
Patrick Williams2a254922023-08-11 09:48:11 -050012
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'LIBPATH=${libdir}' 'CFLAGS=${CFLAGS}'"
16
17do_compile() {
18 oe_runmake -f makefile.shared
19}
20
21do_install() {
22 oe_runmake -f makefile.shared install
23}