blob: 1caa4cd1bbb7806db5fc97e7ea02b7ed371fd5a9 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "the compiling PHP template engine"
2SECTION = "console/network"
3HOMEPAGE = "https://www.smarty.net/"
4
5LICENSE = "GPL-3.0-only"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c0f216b2120ffc367e20f2b56df51b3"
7
8DEPENDS += "php"
9
10SRC_URI = "git://github.com/smarty-php/smarty.git;protocol=https;branch=support/4.3"
11
Patrick Williams03514f12024-04-05 07:04:11 -050012SRCREV = "f4152e9b814ae2369b6e4935c05e1e0c3654318d"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${datadir}/php/smarty3/libs/
18 install -m 0644 ${S}/libs/*.php ${D}${datadir}/php/smarty3/libs/
19
20 install -d ${D}${datadir}/php/smarty3/libs/plugins
21 install -m 0644 ${S}/libs/plugins/*.php ${D}${datadir}/php/smarty3/libs/plugins/
22
23 install -d ${D}${datadir}/php/smarty3/libs/sysplugins
24 install -m 0644 ${S}/libs/sysplugins/*.php ${D}${datadir}/php/smarty3/libs/sysplugins/
25}
26FILES:${PN} = "${datadir}/php/smarty3/"