blob: 31f6ae37fcde37a3075defef9135da32d49744b8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Telepathy IM framework - Python package"
2HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "LGPL-2.1-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \
5 file://src/utils.py;beginline=1;endline=17;md5=9a07d1a9791a7429a14e7b25c6c86822"
6
7DEPENDS = "libxslt-native"
8
9SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-python/telepathy-python-${PV}.tar.gz \
10 file://parallel_make.patch \
11 file://remove_duplicate_install.patch \
12 file://telepathy-python_fix_for_automake_1.12.patch"
13
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15S = "${WORKDIR}/telepathy-python-${PV}"
16
17inherit autotools python3native
18
19SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017"
20SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022FILES:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 ${libdir}/python*/site-packages/telepathy/*.py \
24 ${libdir}/python*/site-packages/telepathy/*/*.py \
25"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027do_install:append () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__
29 rm -fr ${D}${libdir}/python*/site-packages/telepathy/__pycache__
30 rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__
31 rm -fr ${D}${libdir}/python*/site-packages/telepathy/*/__pycache__
32}
Patrick Williams213cb262021-08-07 19:21:33 -050033RDEPENDS:${PN} += "python3-dbus"