blob: e6b980266ed0921f2f96e6e6f1795492cbb2160e [file] [log] [blame]
Patrick Williams03514f12024-04-05 07:04:11 -05001SUMMARY = "Convert WSGI app to ASGI app or ASGI app to WSGI app."
2HOMEPAGE = "https://github.com/abersheeran/a2wsgi"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e10d05d29ec6d8be8bfc503683f1bc9a"
5
6inherit pypi python_setuptools_build_meta ptest
7
8SRC_URI[sha256sum] = "50e81ac55aa609fa2c666e42bacc25c424c8884ce6072f1a7e902114b7ee5d63"
9
10DEPENDS += " \
11 python3-pdm-native \
12 python3-pdm-backend-native \
13"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 python3-httpx \
21 python3-pytest \
22 python3-pytest-asyncio \
23 python3-unittest-automake-output \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}
30
31RDEPENDS:${PN} += " \
32 python3-asyncio \
33"