blob: 7391c3ae2e2d91e87309d23d8bab154b09532816 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "A coverage plugin to provide sensible default settings"
2HOMEPAGE = "https://github.com/asottile/covdefaults"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3da826da635201a80d2fb40f3034929"
5
6# Use GitHub SRC_URI, as pypi package does not include tests
7SRC_URI += " \
8 git://github.com/asottile/covdefaults.git;branch=main;protocol=https \
9 file://run-ptest \
10"
11
12SRCREV = "007f5aff5d1c817883385a5f61f742dd11776dc6"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3 ptest
17
18RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-coverage \
Andrew Geissler8f840682023-07-21 09:09:43 -050020"
21
22RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060023 python3-pytest \
24 python3-unittest-automake-output \
Andrew Geissler8f840682023-07-21 09:09:43 -050025"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}
29 cp -rf ${S}/tests ${D}${PTEST_PATH}
30}