blob: a56296188c040acd63a2215ee43cb4e18c6a6352 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding."
2HOMEPAGE = "https://github.com/ethereum/eth-abi"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=731f4de9c79bfeba6d8d55f83d0d2423"
6
Patrick Williams03514f12024-04-05 07:04:11 -05007SRC_URI[sha256sum] = "e9425110c6120c585c9f0db2e8a33d76c4b886b148a65e68fc0035d3917a3b9c"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9PYPI_PACKAGE = "eth_abi"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN} += " \
14 python3-eth-typing \
15 python3-eth-utils \
16 python3-parsimonious \
17 python3-setuptools \
18"