blob: e4d3cbeee8b721d110bd62663b7c83d3d1338968 [file] [log] [blame]
Patrick Williams73bd93f2024-02-20 08:07:48 -06001SUMMARY = "A next generation HTTP client for Python."
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c624803bdf6fc1c4ce39f5ae11d7bd05"
5
6inherit pypi python_hatchling
7
Patrick Williams03514f12024-04-05 07:04:11 -05008SRC_URI[sha256sum] = "a0cb88a46f32dc874e04ee956e4c2764aba2aa228f650b06788ba6bda2962ab5"
Patrick Williams73bd93f2024-02-20 08:07:48 -06009
10DEPENDS += "\
11 python3-hatch-fancy-pypi-readme-native \
12"
13
14PACKAGECONFIG ??= ""
15PACKAGECONFIG[brotli] = ",,,python3-brotli"
16PACKAGECONFIG[http2] = ",,,python3-h2"
17PACKAGECONFIG[socks] = ",,,python3-socksio"
18
19RDEPENDS:${PN} += "\
20 python3-anyio \
21 python3-certifi \
22 python3-httpcore \
23 python3-idna \
24 python3-sniffio \
Patrick Williams03514f12024-04-05 07:04:11 -050025 python3-json \
26 python3-core \
27 python3-netclient \
28 python3-compression \
Patrick Williams73bd93f2024-02-20 08:07:48 -060029"
30
31PACKAGES += "\
32 ${PN}-cli \
33"
34
35RDEPENDS:${PN}-cli += "\
36 ${PN} \
37 python3-click \
38 python3-pygments \
39 python3-rich \
40"
41
42FILES:${PN} = "\
Patrick Williams39653562024-03-01 08:54:02 -060043 ${libdir}/${PYTHON_DIR} \
Patrick Williams73bd93f2024-02-20 08:07:48 -060044"
45
46FILES:${PN}-cli = "\
Patrick Williams39653562024-03-01 08:54:02 -060047 ${bindir}/httpx \
Patrick Williams73bd93f2024-02-20 08:07:48 -060048"