blob: bf1d8dd2902cfe4cecc9a5f21b3dbd5f2aa755f6 [file] [log] [blame]
Patrick Williamsb58112e2024-03-07 11:16:36 -06001SUMMARY = "Simplified object serialization in python"
2DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
3HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE;md5=27586b20700d7544c06933afe56f7df4 \
7 file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
8
9SRC_URI[sha256sum] = "4e65e9e0d80fc9e609574b9983cf32579f305c718afb30d7233ab818571768c3"
10
11inherit python_flit_core pypi ptest
12
Patrick Williamsb58112e2024-03-07 11:16:36 -060013SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-pytest \
19 python3-pytz \
20 python3-simplejson \
21 python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 rm -rf ${S}/tests/mypy_test_cases
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29
30RDEPENDS:${PN} += " \
31 python3-compression \
32 python3-datetime \
33 python3-email \
34 python3-json \
35 python3-numbers \
36 python3-pprint \
37 python3-packaging \
38"