blob: b12e180d02d67b11a62e54bd841afedd956698e0 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
2HOMEPAGE = "https://github.com/aio-libs/multidict/"
3
4LICENSE = "Apache-2.0"
Patrick Williamsf52e3dd2024-01-26 13:04:43 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=b4fef6e4b0828c2401fb983363985b39"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
7inherit pypi setuptools3 ptest
8
Patrick Williamsf52e3dd2024-01-26 13:04:43 -06009PV .= "+git"
10
Patrick Williams03514f12024-04-05 07:04:11 -050011SRCREV = "a9b281b2ef4ab25d95d6b268aa88c428e75c3696"
Patrick Williamsf52e3dd2024-01-26 13:04:43 -060012PYPI_SRC_URI = "git://github.com/aio-libs/multidict;branch=master;protocol=https"
13S = "${WORKDIR}/git"
14
Andrew Geissler517393d2023-01-13 08:55:19 -060015SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-pytest \
21 python3-pytest-cov \
22 python3-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060023"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29
30BBCLASSEXTEND = "native nativesdk"