blob: f5e6dbfcd2df395a5bad65bce5adc47f7bc74b56 [file] [log] [blame]
Patrick Williams39653562024-03-01 08:54:02 -06001SUMMARY = "Allows you to use fixtures in @pytest.mark.parametrize."
2DESCRIPTION = "Use your fixtures in @pytest.mark.parametrize. \
3\
4This project was inspired by pytest-lazy-fixture.\
5\
6Improvements that have been made in this project:\
7\
8* You can use fixtures in any data structures\
9* You can access the attributes of fixtures\
10* You can use functions in fixtures"
11HOMEPAGE = "https://github.com/dev-petrov/pytest-lazy-fixtures"
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=4475e66fcfabe27395e6764c8f69c876"
14
Patrick Williams03514f12024-04-05 07:04:11 -050015SRC_URI[sha256sum] = "87ef7424dc0229ff9cb72d482f49b7806535c3500641f612c13ddf243c9adacb"
Patrick Williams39653562024-03-01 08:54:02 -060016
17inherit pypi python_poetry_core
18
19PYPI_PACKAGE = "pytest_lazy_fixtures"
20
21RDEPENDS:${PN} = "python3-pytest"