blob: c094a8d6f0b2189f9d1a83a0a0b69eccbf9549ae [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001DESCRIPTION = "Pyzstd module provides classes and functions for compressing and \
2decompressing data, using Facebook’s Zstandard (or zstd as short name) algorithm."
3HOMEPAGE = "https://github.com/animalize/pyzstd"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
Patrick Williams03514f12024-04-05 07:04:11 -05007LIC_FILES_CHKSUM = "file://LICENSE;md5=aedb5a2679cd1552fb61c181ef974b9e"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008
9PYPI_PACKAGE = "pyzstd"
10
Patrick Williams03514f12024-04-05 07:04:11 -050011SRC_URI[sha256sum] = "83603a97fdbcf2139f475c940789f09e32703f931f29f4a8ddf3551e6700108b"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050012
13inherit pypi setuptools3
Andrew Geissler3eeda902023-05-19 10:14:02 -050014
15# clang-16 with -flto segfaults on arm, therefore ignore flto for now
16do_configure:append:arm:toolchain-clang() {
17 sed -i -e "s|'-flto'|''|" ${S}/setup.py
18}