blob: aedf483befad2643300258b470305bfa11a81ebf [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
2DESCRIPTION = "Extract data from Excel spreadsheets (.xls and .xlsx,\
3 versions 2.0 onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). \
4Strong support for Excel dates. Unicode-aware."
5HOMEPAGE = "http://www.python-excel.org/"
6LICENSE = "BSD-3-Clause"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=00ea1e843a43c20d9b63a8112239b0d1"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
Andrew Geisslerac970dd2021-02-12 15:32:45 -06009SRC_URI[sha256sum] = "f72f148f54442c6b056bf931dbc34f986fd0c3b0b6b5a58d013c9aef274d0c88"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Andrew Geisslerac970dd2021-02-12 15:32:45 -060011
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/python-excel/xlrd.git;branch=master;protocol=https \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060013 file://run-ptest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060015SRCREV = "b8d573e11ec149da695d695c81a156232b89a949"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
Andrew Geisslerac970dd2021-02-12 15:32:45 -060017S = "${WORKDIR}/git"
18
19inherit ptest setuptools3
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
Patrick Williamsb542dec2023-06-09 01:26:37 -050021RDEPENDS:${PN} += " \
22 python3-compression \
23 python3-io \
24 python3-mmap \
25 python3-pprint \
26 python3-shell \
27"
Andrew Geissler82c905d2020-04-13 13:39:40 -050028
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN}-ptest += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050030 python3-pytest \
Patrick Williams73bd93f2024-02-20 08:07:48 -060031 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050032"
33
34do_install_ptest() {
35 install -d ${D}${PTEST_PATH}/tests
36 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
Andrew Geissler82c905d2020-04-13 13:39:40 -050037}
38
39BBCLASSEXTEND = "native nativesdk"