blob: 0f00509f0307b144fed7200a088fcbbf2c2c4ab6 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
2
3SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
4HOMEPAGE = " http://golang.org/"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
7
8PROVIDES = "go-native"
9
10# Checksums available at https://go.dev/dl/
11SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
Patrick Williams03514f12024-04-05 07:04:11 -050012SRC_URI[go_linux_amd64.sha256sum] = "5901c52b7a78002aeff14a21f93e0f064f74ce1360fce51c6ee68cd471216a17"
13SRC_URI[go_linux_arm64.sha256sum] = "36e720b2d564980c162a48c7e97da2e407dfcc4239e1e58d98082dfa2486a0c1"
14SRC_URI[go_linux_ppc64le.sha256sum] = "251a8886c5113be6490bdbb955ddee98763b49c9b1bf4c8364c02d3b482dab00"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16UPSTREAM_CHECK_URI = "https://golang.org/dl/"
17UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
18
Patrick Williams169d7bc2024-01-05 11:33:25 -060019CVE_PRODUCT = "golang:go"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050020
Andrew Geissler517393d2023-01-13 08:55:19 -060021S = "${WORKDIR}/go"
22
23inherit goarch native
24
25do_compile() {
26 :
27}
28
29make_wrapper() {
30 rm -f ${D}${bindir}/$1
31 cat <<END >${D}${bindir}/$1
32#!/bin/bash
33here=\`dirname \$0\`
34export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
35\$here/../lib/go/bin/$1 "\$@"
36END
37 chmod +x ${D}${bindir}/$1
38}
39
40do_install() {
41 find ${S} -depth -type d -name testdata -exec rm -rf {} +
42
43 install -d ${D}${bindir} ${D}${libdir}/go
44 cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
45
46 for f in ${S}/bin/*
47 do
48 make_wrapper `basename $f`
49 done
50}