blob: 3e896957d16c1fc0b891618e64fd2f708f6c97d2 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
22TUNE_CCARGS:remove:x86 = "-mfpmath=sse"
23TUNE_CCARGS:remove:x86-64 = "-mfpmath=sse"
24
25CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
26CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Patrick Williams73bd93f2024-02-20 08:07:48 -060027SRCREV = "68737d20556d37364c95776044b1119c0912a36a"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028
29SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
30 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Patrick Williams03514f12024-04-05 07:04:11 -050031 file://0001-scenario_groups-default-remove-connectors.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060032 "
33
34S = "${WORKDIR}/git"
35
36inherit autotools-brokensep pkgconfig
37
38# Version 20220527 added KVM test infrastructure which currently fails to build with gold due to
39# SORT_NONE in linker script which isn't supported by gold:
40# https://sourceware.org/bugzilla/show_bug.cgi?id=18097
41# https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
42LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
43LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -fuse-ld=bfd', '', d)}"
44
45# After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch
46# https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb
47# it fails with gold also a bit later when trying to use *-payload.bin
48# http://errors.yoctoproject.org/Errors/Details/663094/
49# work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES
50KVM_LD = "${@bb.utils.contains_any('DISTRO_FEATURES', 'ld-is-gold ld-is-lld', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
51
52TARGET_CC_ARCH += "${LDFLAGS}"
53
54export prefix = "/opt/${PN}"
55export exec_prefix = "/opt/${PN}"
56
57PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
58EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
59EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
60# ltp network/rpc test cases ftbfs when libtirpc is found
61EXTRA_OECONF += " --without-tirpc "
62
63do_compile() {
64 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" KVM_LD="${KVM_LD}"
65}
66
67do_install(){
68 install -d ${D}${prefix}/
69 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
70
71 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
72 # as it lacks dependency on some perl moudle such as LWP::Simple
73 # And this script previously works as a tool for analyzing failures from LTP
74 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
75 # http://khack.osdl.org to retrieve ltp test results run on
76 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
77 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
78
79 # The controllers memcg_stree test seems to cause us hangs and takes 900s
80 # (maybe we expect more regular output?), anyhow, skip it
81 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
82}
83
84RDEPENDS:${PN} = "\
85 attr \
86 bash \
87 bc \
88 coreutils \
89 cpio \
90 cronie \
91 curl \
92 e2fsprogs \
93 e2fsprogs-mke2fs \
94 expect \
95 file \
96 findutils \
97 gawk \
98 gdb \
99 gzip \
100 iproute2 \
101 ldd \
102 libaio \
103 logrotate \
104 net-tools \
105 perl \
106 python3-core \
107 procps \
108 quota \
109 unzip \
110 util-linux \
111 which \
112 tar \
113"
114
115RRECOMMENDS:${PN} += "kernel-module-loop"
116
117FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
118
119# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
120INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
121INSANE_SKIP:${PN} += "already-stripped staticdev"
122
123remove_broken_musl_sources() {
124 [ "${TCLIBC}" = "musl" ] || return 0
125
126 cd ${S}
127 echo "WARNING: remove unsupported tests (until they're fixed)"
128
129 # sync with upstream
130 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
131 rm -rfv \
132 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
133 testcases/kernel/syscalls/getcontext/getcontext01.c \
134 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
135 testcases/kernel/syscalls/timer_create/timer_create01.c \
136 testcases/kernel/syscalls/timer_create/timer_create03.c
137}
138do_patch[postfuncs] += "remove_broken_musl_sources"
139
140# Avoid file dependency scans, as LTP checks for things that may or may not
141# exist on the running system. For instance it has specific checks for
142# csh and ksh which are not typically part of OpenEmbedded systems (but
143# can be added via additional layers.)
144SKIP_FILEDEPS:${PN} = '1'